Network issues in the EU data center

Incident Report for Bitbar Testing Cloud

Resolved

Issue has been resolved by our service provider.
Posted Nov 19, 2025 - 14:59 UTC

Update

We are continuing to investigate this issue.
Posted Nov 19, 2025 - 07:56 UTC

Investigating

As a side effect of the nightly maintenance from our service provider, some of the services in the EU data center are currently not available.
Posted Nov 19, 2025 - 07:28 UTC
This incident affected: Mobile Hub (Appium Broker) - By Region (Appium Broker EU).